易语言正则表达式提取数字的方法

今天给大家带来一个利用易语言和正则表达式提取数字的例子,我们将会提取一段网页代码中的手机号码信息

易语言正则表达式提取数字的方法
  1. 1
    方法:

    电脑

  2. 2

    易语言开发工具

  3. 3

    精易模块

  4. 4

    首先创建一个易语言空白程序,并且加载精易模块,方便我们后面使用里面的相关功能

    易语言正则表达式提取数字的方法
    易语言正则表达式提取数字的方法
  5. 5

    在基本组件中拖动两个编辑框到我们的程序界面中取,将编辑框的属性更改为是否允许多行为真,一个文本框用来存放我们需要提取的数据,另外一个文本框用来获得我们提取的结果

    易语言正则表达式提取数字的方法
    易语言正则表达式提取数字的方法
  6. 6

    接下来我们添加一个按钮,在属性栏中把标题改为提取

    易语言正则表达式提取数字的方法
  7. 7

    经过以上操作,一个简单的界面就做好了,接下来我们写入相关的代码

    点击界面的窗口处,进入窗口程序集,然后右键新建一个子程序,名称为提取数字。并且创建一个常量,把我们的正则表达式写入进去。

    表达式为:(\d{11})

    易语言正则表达式提取数字的方法
    易语言正则表达式提取数字的方法
    易语言正则表达式提取数字的方法
    易语言正则表达式提取数字的方法
    易语言正则表达式提取数字的方法
    易语言正则表达式提取数字的方法
    易语言正则表达式提取数字的方法
    易语言正则表达式提取数字的方法
  8. 8

    写入相关代码:

    正则表达式.创建 (#常量1, 编辑框1.内容)

    .计次循环首 (正则表达式.取匹配数量 (), i)

        编辑框2.加入文本 (正则表达式.取子匹配文本 (i, 1) + #换行符)

    .计次循环尾 ()

    易语言正则表达式提取数字的方法
  9. 9

    接下来回到刚刚的界面当中,双击提取按钮,进入程序集当中。

    易语言正则表达式提取数字的方法
    易语言正则表达式提取数字的方法
  10. 10

    建立整数型变量为,线程句柄

    然后写入代码:启动线程 (&提取数字, , 线程句柄)

    易语言正则表达式提取数字的方法
  11. 11

    点击运行按钮,开始测试我们的程序,将准备好的网页源码输入进去,然后我们点击提取按钮,发现全部手机号码都提取出来了

    易语言正则表达式提取数字的方法
  12. 12

    代码总结:

    .版本 2

    .支持库 EThread


    .子程序 提取数字

    .局部变量 正则表达式, 正则表达式类

    .局部变量 i, 整数型


    正则表达式.创建 (#常量1, 编辑框1.内容)


    .计次循环首 (正则表达式.取匹配数量 (), i)

        编辑框2.加入文本 (正则表达式.取子匹配文本 (i, 1) + #换行符)


    .计次循环尾 ()


    .子程序 _按钮1_被单击

    .局部变量 线程句柄, 整数型


    启动线程 (&提取数字, , 线程句柄)

    END
注意事项:
  • 注意建立变量的类型需要正确